AIX Administration



(IBM 9117-570 8-Way LPAR managed by Dual HMCs. EMC DMX Frame 2TB, Sepaton Tape Library. OS: AIX, Applications: Sybase ASE 12.5, Veritas VCS. Function: Backend data warehouse)



AIX Paging Space Management


An very good guide for AIX memory usage is at HERE.


; See real memory size
lsattr -El sys0 | grep realmem

bootinfo -r

svmon -G

; Create Paging
mkps -a -n -s8 rootvg hdisk1
mkps -a -n -s4 rootvg hdisk3


#swapon /dev/paging01

#lsps -a


Display paging:

#lsps -a
Page Space Physical Volume Volume Group Size %Used Active Auto Type
hd6 hdisk0 rootvg 512MB 1 yes yes lv
paging00 hdisk0 rootvg 2560MB 1 yes yes lv


Shrink paging space on the fly:

chps -d decrement_LVs -a y|n paging00


Shrink paging00 by 4 LPs and activate the paging on each subsequent reboot

#chps -d 4 -a y paging00 ; reduce swap space


#swapoff /dev/paging00 ; offline swap space

#rmps paging00 ; to remove paging



;all paging space are defined in /etc/swapspaces file

;to activate all paging space at once
swapon -a

;to deactivate paging03 and remove
swapoff /dev/paging03
rmps paging03

;to reduce the size of paging by two LPs
chps -d2 paging03

;paging summary
mkps
rmps
chps
lsps
swapoff
swapon
chps -s
chps -d
shrinkps
svmon
topas
vmstat
sar
istat
slibclean
ps